Jump to content

Photo

1.13+ On The Titan Launcher

94 replies to this topic
  • Please log in to reply

#1
Astelon

Astelon

    Enderdragon Slayer

  • Server Donator
  • 1,308 posts

The Titan Launcher has been updated to 3.8.0, all you have to do is start it and it should update on its own. That means you can now play 1.13 and 1.13.1 without the need for this tutorial.

 

One thing I am not 100% certain about, is whether you only need to get the launcher updated after doing the tutorial. My fix wasn't perfect, there were sound issues from 1.13 that passed over to 1.13.1 if you did the sound fix. I don't know if these will be sorted out by the update, and I'm unable to check as I deleted everything to make sure there were no more issues, so if you still notice sounds/subtitles missing, delete the assets, 1.13 and 1.13.1 folders (the paths to them from .minecraft should be .minecraft/assets and .minecraft/versions/1.13, respectively .minecraft/versions/1.13.1). The launcher will download everything needed properly. Keep in mind that 1.13 version has a few missing subtitles on it's own, nothing you can do about these. 1.13.1 has no sound issue that I noticed.

 

I'm gonna leave the old post here for "posterity", and maybe it's gonna help for later versions.

Spoiler

Edited by Astelon, 23 October 2018 - 03:44 PM.

  • Athu7890, ibu2awesome, BlueTanto and 13 others like this

#2
aleksandrea

aleksandrea

    Wealthy Merchant

  • Server Donator
  • 341 posts

i did this and i can't get on MC in 1.13 it works in 1.12.2. But all it does is sit there when i hit play. And yes i changed the files around


Edited by aleksandrea, 27 July 2018 - 08:11 PM.

                                                                 P7vir2q.gif

 

 


#3
Maaz12

Maaz12

    Wealthy Merchant

  • Server Donator
  • 292 posts

Doesnot works ...


Posted Image
Thanks to Alphautry for tis amazing sig!

#4
Slateyo

Slateyo

    Master of Doughnuts.

  • Server Donator
  • 2,213 posts

if you download the client from the website Astelon provided, make sure its named 'client.jar' and not '$'


Posted Image


#5
aleksandrea

aleksandrea

    Wealthy Merchant

  • Server Donator
  • 341 posts

it is


                                                                 P7vir2q.gif

 

 


#6
Magical_Sapphire

Magical_Sapphire

    Noobie

  • Members
  • 2 posts

Doesnt work



#7
Maaz12

Maaz12

    Wealthy Merchant

  • Server Donator
  • 292 posts

if you download the client from the website Astelon provided, make sure its named 'client.jar' and not '$'

did it but it gives this error

Spoiler

Posted Image
Thanks to Alphautry for tis amazing sig!

#8
Maaz12

Maaz12

    Wealthy Merchant

  • Server Donator
  • 292 posts

Any1 knows how to fix it up?


Posted Image
Thanks to Alphautry for tis amazing sig!

#9
Astelon

Astelon

    Enderdragon Slayer

  • Server Donator
  • 1,308 posts

did it but it gives this error

You sure downloaded the json from here?
https://cdn.discorda...55380/1.13.json

 

i did this and i can't get on MC in 1.13 it works in 1.12.2. But all it does is sit there when i hit play. And yes i changed the files around

Show me your .minecraft/versions/1.13 folder. Also, it's got nothing to do with 1.12.2 or any other version before that. This is solely for 1.13.



#10
aleksandrea

aleksandrea

    Wealthy Merchant

  • Server Donator
  • 341 posts
Screenshot (2)

                                                                 P7vir2q.gif

 

 


#11
aleksandrea

aleksandrea

    Wealthy Merchant

  • Server Donator
  • 341 posts

the Client is the bottom one


                                                                 P7vir2q.gif

 

 


#12
Astelon

Astelon

    Enderdragon Slayer

  • Server Donator
  • 1,308 posts

the Client is the bottom one

The names of both files need to be exactly 1.13. Not 1.13 (2), not client (2). Only 1.13 (along with the file extension which may or may not be hidden). I suppose I'll have to mention that in the original post >_>



#13
aleksandrea

aleksandrea

    Wealthy Merchant

  • Server Donator
  • 341 posts

file extension?


                                                                 P7vir2q.gif

 

 


#14
Astelon

Astelon

    Enderdragon Slayer

  • Server Donator
  • 1,308 posts

file extension?

Just rename both files to 1.13 and you shouldn't have any issue



#15
_WhiteArcher_

_WhiteArcher_

    Wealthy Merchant

  • Server Donator
  • 294 posts

you should wait for optifine of 1.13 by the way. it has really really bad fps and render issues



#16
Maaz12

Maaz12

    Wealthy Merchant

  • Server Donator
  • 292 posts

You sure downloaded the json from here?
https://cdn.discorda...55380/1.13.json

 

Show me your .minecraft/versions/1.13 folder. Also, it's got nothing to do with 1.12.2 or any other version before that. This is solely for 1.13.

massive thank you! it works!


  • Astelon and Vercingetorix like this
Posted Image
Thanks to Alphautry for tis amazing sig!

#17
Astelon

Astelon

    Enderdragon Slayer

  • Server Donator
  • 1,308 posts

you should wait for optifine of 1.13 by the way. it has really really bad fps and render issues

Or instead of just listening to him, you can try it out yourself and see how it's handled. I've had 0 issues whatsoever with 1.13. If your laptop/pc is a potato, of course there'll be issues no matter the version.



#18
cupcakes11

cupcakes11

    Noobie

  • Members
  • 1 posts

So I did everything, added the folder, added the .Jar file then the top .Json file and got it all to e ine and dandy.Pressed play, downloaded all the things and said launching ut just as it was about to launch I got an error that says:

 

Error: Could not find or load main class net.minecraft.client.main.Main
Java HotSpot™ 64-Bit Server VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
 
My account is on default so that shouldn't e a problem, does this mean I have to reinstall minecraft??

This applies only to the current (3.7.0) version of the Titan Launcher. If you use any other launcher, there is no guarantee it will work. As of now, the launcher does not support 1.13 as it is due to some changes mojang made (and for some, it doesn't even appear in the list of versions), but this can be solved by changing the 1.13.json file of the version to the one at this link
https://cdn.discorda...55380/1.13.json

If you can select 1.13 in the version list but the game refuses to start from the launcher (you press play but nothing seemingly happens), go to .minecraft/versions/1.13 and replace the 1.13.json file there with the one above.

If you can't find 1.13 in the version list, you'll need to download the jar yourself. First, go to .minecraft/versions and make a folder called 1.13. Then, go to https://minecraft.gamepedia.com/1.13 and download the client from there. Put it inside the folder you created and rename it to 1.13. Then, put the 1.13.json from above inside the same folder.

 

You only have to do the above once. After that, you should be able to play 1.13 without making any change.

 

After you are done, inside .minecraft/versions must be a folder called 1.13 that contains a json file named 1.13 and a jar file named 1.13. They must have these names, or else it won't work.

(I hope you at least understand what file extensions are and that the files might appear as 1.13.json or 1.13.jar instead of just 1.13)


Edited by cupcakes11, 05 August 2018 - 03:30 AM.


#19
Astelon

Astelon

    Enderdragon Slayer

  • Server Donator
  • 1,308 posts

 

So I did everything, added the folder, added the .Jar file then the top .Json file and got it all to e ine and dandy.Pressed play, downloaded all the things and said launching ut just as it was about to launch I got an error that says:

 

Error: Could not find or load main class net.minecraft.client.main.Main
Java HotSpot™ 64-Bit Server VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
 
My account is on default so that shouldn't e a problem, does this mean I have to reinstall minecraft??

 

Seems like you might have to. Though, try redownload the 1.13 jar file. It might not have been downloaded properly. If that fails, reinstall mc (you'll have to do the tutorial again), and check if there's any java update, just in case.



#20
Plingwings

Plingwings

    Noobie

  • Members
  • 7 posts
Its nice and works great
  • Astelon likes this


Also tagged with one or more of these keywords: 1.13

4 user(s) are reading this topic

0 members, 4 guests, 0 anonymous users